« January »
January
Jan 3 - Aisha Day
Jan 6 - Gnorbu Day
Jan 11 - Buzz Day
Jan 14 - Sloth Day
Jan 16 - Elephante Day
Jan 29 - Kacheek Day


Neopia's Award Ceremony for your top picks of the year!
All the hottest looks, try them on today!
Every editorial question answered just a search away!
A searchable database of Neopets images
Your jnAccount! Your jnAccount: Log In or Register | New to Jellyneo? Click here!

Welcome to Jellyneo.net!

Welcome to Jellyneo, the #1 ad-free Neopets help site! We offer news and tips for the popular online game Neopets. Here's what you can find on the site:

You can also register a jnAccount; it's free and lets you access special features! (Find out more!)

Pick your news: Neopets News Jellyneo's Twitter | Crossword | JN Updates | Daily Puzzle | Neopies

Herdy
January NC Collectible
  • Posted by Herdy
  • Posted on January 5, 2021, 5:09 am NST

The second item for the Lost in Space II Collection has been released, and features the S750 Kreludan Defender Robot! This item will only be available during January.







Follow @jellyneo on Twitter for all the latest #Neopets news!

There are 5 comments below. Add yours!


cinnamon_girl, January 5, 2021 11:12 AM NST
Hey team Jellyneo, lately many of the images here aren't loading for me. I've tried clearing my cache and hard resets, and the image url works when I open it in a new tab, but they just won't load for me here on JN. Some images do show up though, so I don't really know where the problem lies. None of the four images here in the Jan 5 post are loading for instance, and in the previous post (4th of Jan) only the separate clothing items at the bottom are visible, but not the Neopets wearing the items. This is happening around more pages on this site (for instance the Shenkuu Lunar Temple page doesn't load any of the moon images in calculations, but the rest of the page loads fine). Do you have any idea how I can fix this?
maple_snow, January 5, 2021 11:38 AM NST
None of the on-site images on JN for the Rainbow Pool feature had been loading for me, for weeks now. But I never reported it a bug, because the images load separately when opened in a new tab.
dave - JN Staff, January 5, 2021 1:03 PM NST
@cinnamon_girl @maple_snow: The issue is with Chrome and Neopets. A few months ago, Chrome released an update that refuses to load HTTP image content on HTTPS URLs. Since Neopets has not updated their images.neopets.com domain to support HTTPS, and we at Jellyneo provide an HTTPS version of the site, you will not see those images.

You have one of two options: (a) switch to another browser, such as Firefox, or (b) simply change "HTTPS" in the Jellyneo URL you're visiting to be "HTTP" instead. We still offer the HTTP version of Jellyneo.

For example, on this page, you might see broken images from Neopets: https://www.jellyneo.net/?comments=13679

Viewing this URL instead in Chrome should do the trick: http://www.jellyneo.net/?comments=13679

As soon as TNT pushes a fix on their end, we'll be updating everything we can here on Jellyneo.
cinnamon_girl, January 6, 2021 3:31 AM NST
Thank you so much for explaining!! <3
escrainus, January 8, 2021 1:36 PM NST
Firefox works just like Chrome

Add Your Comment

Want to add your thoughts? You just need to log into your jnAccount!

Log In Your jnAccount Register a jnAccount Your jnAccount

Jellyneo on Twitter
Get JN updates via Twitter!
Jellyneo on YouTube
Find our latest gaming videos on YouTube!
Old Neopets News
Looking for older Neopets news?